Home

i-MSCP - Internet Multi Server Control Panel (Open Source)

This site uses cookies. By continuing to browse this site, you are agreeing to our use of cookies. More details

Latest Release ( Serie 1.2.x ): 1.2.9

1.2.x Git Branch Status: Working

develop Git Branch Status: Working

About Git Branches Status

i-MSCP - internet Multi Server Control Panel

internet Multi Server Control Panel (i-MSCP) is a open-source project aimed to build an impressive and powerful Multi Server Control panel for personal and professional usage. Its purpose is to allow management of any shared hosting environment in an easy way without any human intervention on the server file system.

  • Event Manager (frontEnd and Backend)
  • External Mail Server
  • MySQL|MariaDB support
  • Remote SQL server support
  • Plugin API (frontEnd and backend)
  • Preseeding feature for unattended installation
  • Web folder protection using FS immutable bit
  • Web server management (Apache2 ITK, Fcgid and FastCGI/PHP5-FPM)
  • Mail Server management (Postfix, Courier, Dovecot), both with quota support
  • SQL server management (MySQL)
  • Multi-user level Web interface (administrator, reseller and client)
  • PHP settings Editor (per user, per domain or per site)
  • Custom DNS records
  • Software package installer
  • And a lot more...


i-MSCP 1.2.9 Released

i-MSCP 1.2.9 is now available for download. This is a maintenance release.

See github.com/i-MSCP/imscp/releases

System Requirements


General
  • 1 GHz or faster 32-bit (x86) or 64-bit (x64) processor
  • 512 MO memory (minimum) - For heavily loaded servers or high flow is recommended at least 8 GiB
  • 1 GB of available hard disk space (only for i-MSCP and services managed by the same)
  • Internet access (at least 100 Mbits/s recommended)
  • A file system that supports extended attributes such as ext2, ext3, ext4 and reiserfs**.


** See Using reiserfs file system with i-MSCP

Distribution
  • Debian >= Wheezy
  • Ubuntu LTS >= Precise Pangolin


Software and Co...
  • PHP >= 5.3.2
  • Perl >= 5.14.2